Java Applet is no longer supported

Starting from ID-software version 3.7 the Java Applet browser signing plugin is not supported. ID-software version 3.7 doesnt contain the PKCS#11 wrapper module that the Java Applet uses in Windows operating systems.
All web and information systems that still use Java Applet should migrate to browser based digital signing component (plugin). Otherwise its not possible to digitally sign in those services with operating systems that used Java Applet.
Browser based plugin has been distributed as a part of ID-software since 2010 october and is the only officially supported digital signing component.
ID-software version 3.7 was published on website 22.01.2013 and automatic software update for older versions is planned to be enabled around 25.02.2013
Web service developer should migrate to latest idCard.js version (0.12), where the support for Java Applet component identification and loading has been removed. 
Java Applet is an outdated and insecure component which has officially never been the part of ID-software. 

For further questions email us on: support at sk dot ee


If you didn't find an answer to your question, send it to our team.

  • See instructions
  • Please estimate your ability to use the computer, so that we can provide you with the best guidance


  • Verification failed

How can we improve the article and be more helpful?
Send Close