Mac OS X 10.11.4 and later - No readers found

In operating systems Mac OS X 10.11.4 and later you may encounter a situation where the ID-card utility, DigiDoc3 Client and Crypto do not find your smartcard reader.

It's a known OSX issue that is described, for example, here:

The solution is to upgrade your operating system to version 10.11.6 or higher. 

To upgrade your operating system, do the following:

  • click on the Apple icon at the upper left corner and select 'About this Mac';
  • click on the 'Software Update' button and follow instructions displayed on the screen.

After upgrade restart your computer. Once it's done, check whether the ID card utility and/or DigiDoc3 –°lient/–°rypto find the smartcard reader plugged into your computer. The problem should now be solved!

If errors persist then try doing this:

  • download this ccid smart card reader driver package;
  • open dmg file and run ccid-installer by rightclicking on it and choose Open With > Installer and confirm it by clicking Open once again;
  • follow the onscreen instructions given by the wizard and after successful installation please restart your computer again;

If upgrading the operating system or installing the driver package didn't help, please contact us at abi at id dot ee.


ASK FOR HELP

If you didn't find an answer to your question, send it to our team.



  • See instructions
  • Please estimate your ability to use the computer, so that we can provide you with the best guidance

         

  • Verification failed

How can we improve the article and be more helpful?
Send Close