При подписывании в веббраузере больше не поддерживается Java Applet

31.01.2013

Начиная с версии 3.7 программное обеспечение ID-карты больше не поддерживает Java Applet. В версии 3.7 отсутствует модуль PKCS#11 wrapper, который используется Java Applet'ом в операционных системах Windows.

Все э-услуги и инфосистемы, в которых используется Java Applet, должны заменить его компонент (плагин) браузерооснованного подписывания. В противном случае пользователи операционных систем, использующих Java Applet, не смогут подписывать документы с помощью ID-карты в этих услугах.

Браузерооснованный плагин входит в состав базового программного обеспечения с октября 2010 года. Он является единственным компонентом, имеющим официальную поддержку программного обеспечения ID-карты.

Программное обеспечение ID-карты версии 3.7 было опубликовано на странице  installer.id.ee 22.01.2013. Запуск автоматического обновления более старых версий программного обеспечения запланирован примерно на 25.02.2013.

Разработчик инфосистем должен перейти на последнюю версию idCard.js (0.12), в которой удалена поддержка обнаружения и загрузки Java Applet. 

Java Applet является устаревшим и ненадежным компонентом, который никогда не был частью программного обеспечения ID-карты.

С возникшими вопросами обращайтесь на адрес электронной почты support at sk dot ee
.


ПОЛУЧИТЬ ПОМОЩЬ

Если Вы не нашли ответа на свой вопрос, свяжитесь с нашей командой.



  • Смотреть руководство
  • Оцените свой уровень владения компьютером, чтобы мы могли предложить Вам более качественные руководства

         

  • Проверка не удалось

Как мы можем улучшить эту cтатью?
Отправить Закрывать