An error "ID Updater package is required" during software installation.

If you see during ID-card installation an error "ID updater package is required" (see picture)...:

... then as a possible solution try this:

  • download and install required ID Updater from here;
  • after successful installation try to install ID-card software again, should succeed;
  • if during install you still do see an error like this, then download and install this version of ID Updater. After that try installing eID software again, must succeed.

IF the error is not solved, then:

  • open Start, type there Run and press Enter;
  • a window opens, type there %temp% and press again Enter;
  • type to top right corner eID and find all log files named eID_software* (see screenshot), save them to Desktop, send to abi at id dot ee via next e-mail and wait for further instructions.

ASK FOR HELP

If you didn't find an answer to your question, send it to our team.



  • See instructions
  • Please estimate your ability to use the computer, so that we can provide you with the best guidance

         

  • Verification failed

How can we improve the article and be more helpful?
Send Close