ID-tarkvara teadaolevad puudused

Mitte ükski tarkvara ei ole täiuslik: koos ajaga muutuvad nii tehnilised võimalused kui vajadused. Iga uue ID-tarkvara versiooniga püütakse lahendada võimalikult palju teadaolevaid puuduseid, ent esikohal on alati kasutaja ning tema andmete turvalisuse tagamine ning tarkvara töökindlus.

Huvi korral saad lugeda ka, milliseid on olnud muudatused ID-tarkvara eelmistes versioonides.

Allpool on toodud teadaolevad puudused, mis esinevad ID-tarkvara viimases versioonis 22.6 Windows, macOS ja Linux:

DigiDoc4 klient

  • DigiDoc4 ei kasuta Ubuntu ja macOS all süsteemseid proksi-seadeid. (IB-5533)
  • Kui Ubuntus on kolm DigiDoc4 akent avatud, küsitakse PIN-koodi ning kuvatakse veateade vales aknas. (IB-5808)
  • Soome ID-kaardiga allkirjastamisel kuvatakse DigiDoc4 kliendis “Palun kontrollige oma arvuti kellaega” isegi siis kui arvuti kellaeg/ajatsoon on õige. (IB-6281)
  • Suure DDOC faili avamine ebaõnnestub. (IB-6868)
  • Krüptoadressaadi otsing LDAP kataloogist ebaõnnestub kui kasutusel on puhverserver. (IB-7077)
  • Osadel Ubuntu 22.04 kasutajatel ebaõnnestub DigiDoc4 kliendis ja Web eID’s ID-kaardi kasutamine pcscd teenuses esineva vea tõttu. Pcscd teenuse taaskäivitamiseks vajalikud juhised leiab siit.

RIA DigiDoc mobiilirakendus

  • Android nutiseadmetes ei ole võimalik avada .DDOC või .CDOC laiendiga faile läbi Google Drive keskkonna. (MOPPAND-603)
  • Osades Android nutiseadmetes ebaõnnestub RIA DigiDoc rakendusega allkirjastamine kui kasutusel on Knox viirusetõrje. (MOPPAND-723)

Veebilehitsejad

  • Safaris autentimisel Cancel nupule vajutades ei kuvata DigiDoc4 kliendis lugejas oleva kaardi andmeid. Aitab kaardilugeja eemaldamine. (IB-5726)
  • Ubuntus autentimine ebaõnnestub, kui kaart vahepeal lugejast eemaldatud, aitab veebilehitseja restart. (IB-6085)
  • Ubuntu 21.10 ja Ubuntu 22.04 on vaikimisi paigaldatud Firefox SNAP-na, milles ei saa ID-kaarti kasutada veebis autentimiseks ja allkirjastamiseks. Firefoxi veebilehitsejas ID-kaardiga veebis autentimiseks ja allkirjastamiseks tuleb paigaldada Firefoxi tavaversioon. (Firefoxi bugiraport)
  • Firefoxi turvaseadmete alla jääb peale PKCS11 loader laienduse eemaldamist alles OpenSC PKCS#11 Moodul. Mooduli eemaldamiseks ava Firefoxi sätete alt turvaseadmed, tee OpenSC PKCS#11 moodul aktiivseks ning vajuta eemalda.

Ekraanilugejad

  • Ekraanilugeja loeb allkirja detailide avamiseks teksti mitu korda. (IB-5948)
  • JAWS ekraanilugeja loeb faili lisamisel ette nii hiirekasutajate kui ka klaviatuurikasutajate käitumisvihje. (IB-6073)

Kaardilugejad

  • Firefox veebilehitsejas ei näidata PinPad kaardilugeja kasutamisel vale koodi sisestamisel veateadet arvuti ekraanil. Veateadet kuvatakse (lühiajaliselt) pinpad lugeja ekraanil. (Firefoxi bugiraport)
  • PinPad lugeja ekraanil öeldakse “Sisesta PUK” asemel “Sisesta PIN”. (IB-5815)