To sign using mobile-ID, you have to update the DigiDoc4 client and the RIA DigiDoc mobile application

05.10.2020

From 1 October, it will not be possible to sign with mobile-ID using older DigiDoc4 clients and RIA DigiDoc versions, as SK ID Solutions AS will close the DigiDocService service used in older software versions.

To sign with mobile ID, you need to install DigiDoc4 client version 4.2.4 or newer and RIA DigiDoc version 2.4.0.

The latest version of the DigiDoc4 client can be downloaded from the website http://www.id.ee. macOS users can find the DigiDoc4 Client in the App Store.

The latest version of RIA DigiDoc can be downloaded from App Store and Google Play.